using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+=\w+(?:\h+\w+)*\b(?!=)";
string input = @"a,b,c,test1=0 test2=1 test3=2 test4=3 test5 Request=4,test6_r_a=5,d,e,f";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}