re = /\w+=\w+(?:\h+\w+)*\b(?!=)/m
str = 'a,b,c,test1=0 test2=1 test3=2 test4=3 test5 Request=4,test6_r_a=5,d,e,f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end