use strict;
my $str = 'a,b,c,test1=0 test2=1 test3=2 test4=3 test5 Request=4,test6_r_a=5,d,e,f';
my $regex = qr/\w+=\w+(?:\h+\w+)*\b(?!=)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}