import re
regex = re.compile(r"\w+=\w+(?:\h+\w+)*\b(?!=)", flags=re.MULTILINE)
test_str = "a,b,c,test1=0 test2=1 test3=2 test4=3 test5 Request=4,test6_r_a=5,d,e,f"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")