const regex = /^(...)\s.*(\-[A-Z]{4}\s.{11}).*\s+(.{31})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(...)\\s.*(\\-[A-Z]{4}\\s.{11}).*\\s+(.{31})', 'g')
const str = `NY1 00000000847727342FHKSF-EAIO B! 00000002N\$@FA! !000000000000000000000000650GHK`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}