import re
regex = re.compile(r"^(...)\s.*(\-[A-Z]{4}\s.{11}).*\s+(.{31})")
test_str = "NY1 00000000847727342FHKSF-EAIO B! 00000002N$@FA! !000000000000000000000000650GHK"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")