$re = '/^(...)\s.*(\-[A-Z]{4}\s.{11}).*\s+(.{31})/';
$str = 'NY1 00000000847727342FHKSF-EAIO B! 00000002N$@FA! !000000000000000000000000650GHK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);