re = /^(...)\s.*(\-[A-Z]{4}\s.{11}).*\s+(.{31})/
str = 'NY1 00000000847727342FHKSF-EAIO B! 00000002N$@FA! !000000000000000000000000650GHK'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end