using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9]{1,3}), ?\1, ?\1$";
string input = @"21,21,21
155,155,155
0, 0, 0
121,191,121
aaa,bbb,ccc
1,97,2,0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}