re = /^([0-9]{1,3}), ?\1, ?\1$/m
str = '21,21,21
155,155,155
0, 0, 0
121,191,121
aaa,bbb,ccc
1,97,2,0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end