import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]{1,3}), ?\\1, ?\\1$";
final String string = "21,21,21\n"
+ "155,155,155\n"
+ "0, 0, 0\n"
+ "121,191,121\n"
+ "aaa,bbb,ccc\n"
+ "1,97,2,0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}