const regex = /^([0-9]{1,3}), ?\1, ?\1$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]{1,3}), ?\\1, ?\\1$', 'gm')
const str = `21,21,21
155,155,155
0, 0, 0
121,191,121
aaa,bbb,ccc
1,97,2,0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}