package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{2,3}[- ]?\d{2}[- ]?\d{4,5}`)
var str = `12-3456789
123456789
123 45 6789
123-45-6789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}