// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{2,3}[- ]?\d{2}[- ]?\d{4,5}").unwrap();
let string = "12-3456789
123456789
123 45 6789
123-45-6789";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}