re = /\d{2,3}[- ]?\d{2}[- ]?\d{4,5}/m
str = '12-3456789
123456789
123 45 6789
123-45-6789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end