$re = '/\d{2,3}[- ]?\d{2}[- ]?\d{4,5}/m';
$str = '12-3456789
123456789
123 45 6789
123-45-6789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);