using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=/Joseph/)|\G(?!\A)/)[^=]+=([^=/]+)";
string input = @"home://Joseph/age=20/race=human/height=170/etc";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}