$re = '@(?:(?<=/Joseph/)|\G(?!\A)/)[^=]+=([^=/]+)@';
$str = 'home://Joseph/age=20/race=human/height=170/etc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);