const regex = new RegExp('(?:(?<=/Joseph/)|\\G(?!\\A)/)[^=]+=([^=/]+)', 'g')
const str = `home://Joseph/age=20/race=human/height=170/etc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}