re = /(?:(?<=\/Joseph\/)|\G(?!\A)\/)[^=]+=([^=\/]+)/
str = 'home://Joseph/age=20/race=human/height=170/etc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end