#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^-]+) - ([^-]+) - ([0-9]+\.) (.*)$"
Local $sString = "Nirvana - From The Muddy Banks Of The Whiskah - 01. Intro.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 02. School.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 03. Drain You.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 04. Aneurysm.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 05. Smells Like Teen Spirit.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 06. Been A Son.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 07. Lithium.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 08. Sliver.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 09. Spank Thru.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 10. Scentless Apprentice.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 11. Heart-Shaped Box.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 12. Milk It.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 13. Negative Creep.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 14. Polly.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 15. Breed.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 16. Tourette's.mp3" & @CRLF & _
"Nirvana - From The Muddy Banks Of The Whiskah - 17. Blew.mp3"
Local $sSubst = "$3 Album: $2 From $1 - $4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)