use strict;
my $str = 'Nirvana - From The Muddy Banks Of The Whiskah - 01. Intro.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 02. School.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 03. Drain You.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 04. Aneurysm.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 05. Smells Like Teen Spirit.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 06. Been A Son.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 07. Lithium.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 08. Sliver.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 09. Spank Thru.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 10. Scentless Apprentice.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 11. Heart-Shaped Box.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 12. Milk It.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 13. Negative Creep.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 14. Polly.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 15. Breed.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 16. Tourette\'s.mp3
Nirvana - From The Muddy Banks Of The Whiskah - 17. Blew.mp3';
my $regex = qr/^([^-]+) - ([^-]+) - ([0-9]+\.) (.*)$/mp;
my $subst = '$3 Album: $2 From $1 - $4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";