import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^-]+) - ([^-]+) - ([0-9]+\\.) (.*)$";
final String string = "Nirvana - From The Muddy Banks Of The Whiskah - 01. Intro.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 02. School.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 03. Drain You.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 04. Aneurysm.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 05. Smells Like Teen Spirit.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 06. Been A Son.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 07. Lithium.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 08. Sliver.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 09. Spank Thru.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 10. Scentless Apprentice.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 11. Heart-Shaped Box.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 12. Milk It.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 13. Negative Creep.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 14. Polly.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 15. Breed.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 16. Tourette's.mp3\n"
+ "Nirvana - From The Muddy Banks Of The Whiskah - 17. Blew.mp3";
final String subst = "$3 Album: $2 From $1 - $4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}