package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)
(?(DEFINE)
(?<M>
(?=
(?=\w*+\W++((?>\w*?(?P=c))))
(?>\w*?(?P=c)(*COMMIT)(?=\w*+\W++\g{-1}((?>\g{-1}?+\w*?(?P=c)))))*+
)
)
)
\b(?:(?<c>\w)(?&M)(?=\w*+\W++(\g{-1}?+\w)))++\W++\g{-1}\b`)
var str = `fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo
now we go with smart trams maps amps because declamations anecdotalism
reoccupation cornucopiate
aaab bbba abab babb
aaab bbba
abab abbb
bbaa bbba
bbaa abab`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}