import Foundation
let pattern = #"""
(?x)
(?(DEFINE)
(?<M>
(?=
(?=\w*+\W++((?>\w*?(?P=c))))
(?>\w*?(?P=c)(*COMMIT)(?=\w*+\W++\g{-1}((?>\g{-1}?+\w*?(?P=c)))))*+
)
)
)
\b(?:(?<c>\w)(?&M)(?=\w*+\W++(\g{-1}?+\w)))++\W++\g{-1}\b
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo
now we go with smart trams maps amps because declamations anecdotalism
reoccupation cornucopiate
aaab bbba abab babb
aaab bbba
abab abbb
bbaa bbba
bbaa abab
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)