import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)\n"
+ "(?(DEFINE)\n"
+ " (?<M>\n"
+ " (?=\n"
+ " (?=\\w*+\\W++((?>\\w*?(?P=c))))\n"
+ " (?>\\w*?(?P=c)(*COMMIT)(?=\\w*+\\W++\\g\\{-1\\}((?>\\g\\{-1\\}?+\\w*?(?P=c)))))*+\n"
+ " )\n"
+ " )\n"
+ ")\n"
+ "\\b(?:(?<c>\\w)(?&M)(?=\\w*+\\W++(\\g\\{-1\\}?+\\w)))++\\W++\\g\\{-1\\}\\b";
final String string = "fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo\n"
+ "now we go with smart trams maps amps because declamations anecdotalism\n"
+ "reoccupation cornucopiate\n\n"
+ "aaab bbba abab babb\n\n"
+ "aaab bbba\n\n"
+ "abab abbb\n\n"
+ "bbaa bbba\n\n"
+ "bbaa abab";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}