$re = '/(?x)
(?(DEFINE)
(?<M>
(?=
(?=\w*+\W++((?>\w*?(?P=c))))
(?>\w*?(?P=c)(*COMMIT)(?=\w*+\W++\g{-1}((?>\g{-1}?+\w*?(?P=c)))))*+
)
)
)
\b(?:(?<c>\w)(?&M)(?=\w*+\W++(\g{-1}?+\w)))++\W++\g{-1}\b/';
$str = 'fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo
now we go with smart trams maps amps because declamations anecdotalism
reoccupation cornucopiate
aaab bbba abab babb
aaab bbba
abab abbb
bbaa bbba
bbaa abab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);