#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(seuil|d[ée]tecteurs?|variateur|dalles?|seuil)(lumineux?|lumineuses?|luminosit[ée])"
Local $sString = "locaux lumineux" & @CRLF & _
"locaux traversants et lumineux" & @CRLF & _
"locaux rénovés sont lumineux" & @CRLF & _
"local commercial de 47 m² très lumineux" & @CRLF & _
"" & @CRLF & _
"bureaux lumineux" & @CRLF & _
"bureaux très lumineux" & @CRLF & _
"bureaux haussmaniens ultra-lumineux" & @CRLF & _
"bureaux cloisonnés et lumineux" & @CRLF & _
"bureaux neufs et lumineux" & @CRLF & _
"bureau privatif cosy et lumineux " & @CRLF & _
"bureaux agréables et lumineux" & @CRLF & _
"" & @CRLF & _
"openspace lumineux" & @CRLF & _
"espaces de travail sont lumineux" & @CRLF & _
"plateaux très lumineux" & @CRLF & _
"plateaux sont très lumineux" & @CRLF & _
"duplex atypique et lumineux" & @CRLF & _
"bien agencé et lumineux" & @CRLF & _
"" & @CRLF & _
"surface lumineuse" & @CRLF & _
"boutique très lumineuse" & @CRLF & _
"" & @CRLF & _
"locaux en état d'usage belle luminosité" & @CRLF & _
"bénéficie d’une luminosité" & @CRLF & _
"offrants une grande luminosité" & @CRLF & _
"en angle et d’une belle luminosité" & @CRLF & _
"verrière apportant élégance et luminosité" & @CRLF & _
"belle luminosité" & @CRLF & _
"grande luminosité" & @CRLF & _
"bonne luminosité" & @CRLF & _
"hauteur sous plafond lumineux" & @CRLF & _
"" & @CRLF & _
"[NE PAS TENIR COMPTE]" & @CRLF & _
"seuil de luminosité" & @CRLF & _
"détecteurs présence et luminosité" & @CRLF & _
"variateur en fonction de la luminosité" & @CRLF & _
"points lumineux" & @CRLF & _
"pavés lumineux" & @CRLF & _
"zone d'activité lumineuse" & @CRLF & _
"dalle quartz belle luminosité" & @CRLF & _
"dalles lumineuses" & @CRLF & _
"plafond en dalle minérale points lumineux" & @CRLF & _
"cage d'escalier très lumineuse"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")