package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(seuil|d[ée]tecteurs?|variateur|dalles?|seuil)(lumineux?|lumineuses?|luminosit[ée])`)
var str = `locaux lumineux
locaux traversants et lumineux
locaux rénovés sont lumineux
local commercial de 47 m² très lumineux
bureaux lumineux
bureaux très lumineux
bureaux haussmaniens ultra-lumineux
bureaux cloisonnés et lumineux
bureaux neufs et lumineux
bureau privatif cosy et lumineux
bureaux agréables et lumineux
openspace lumineux
espaces de travail sont lumineux
plateaux très lumineux
plateaux sont très lumineux
duplex atypique et lumineux
bien agencé et lumineux
surface lumineuse
boutique très lumineuse
locaux en état d'usage belle luminosité
bénéficie d’une luminosité
offrants une grande luminosité
en angle et d’une belle luminosité
verrière apportant élégance et luminosité
belle luminosité
grande luminosité
bonne luminosité
hauteur sous plafond lumineux
[NE PAS TENIR COMPTE]
seuil de luminosité
détecteurs présence et luminosité
variateur en fonction de la luminosité
points lumineux
pavés lumineux
zone d'activité lumineuse
dalle quartz belle luminosité
dalles lumineuses
plafond en dalle minérale points lumineux
cage d'escalier très lumineuse`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}