# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(seuil|d[ée]tecteurs?|variateur|dalles?|seuil)(lumineux?|lumineuses?|luminosit[ée])"
test_str = ("locaux lumineux\n"
"locaux traversants et lumineux\n"
"locaux rénovés sont lumineux\n"
"local commercial de 47 m² très lumineux\n\n"
"bureaux lumineux\n"
"bureaux très lumineux\n"
"bureaux haussmaniens ultra-lumineux\n"
"bureaux cloisonnés et lumineux\n"
"bureaux neufs et lumineux\n"
"bureau privatif cosy et lumineux \n"
"bureaux agréables et lumineux\n\n"
"openspace lumineux\n"
"espaces de travail sont lumineux\n"
"plateaux très lumineux\n"
"plateaux sont très lumineux\n"
"duplex atypique et lumineux\n"
"bien agencé et lumineux\n\n"
"surface lumineuse\n"
"boutique très lumineuse\n\n"
"locaux en état d'usage belle luminosité\n"
"bénéficie d’une luminosité\n"
"offrants une grande luminosité\n"
"en angle et d’une belle luminosité\n"
"verrière apportant élégance et luminosité\n"
"belle luminosité\n"
"grande luminosité\n"
"bonne luminosité\n"
"hauteur sous plafond lumineux\n\n"
"[NE PAS TENIR COMPTE]\n"
"seuil de luminosité\n"
"détecteurs présence et luminosité\n"
"variateur en fonction de la luminosité\n"
"points lumineux\n"
"pavés lumineux\n"
"zone d'activité lumineuse\n"
"dalle quartz belle luminosité\n"
"dalles lumineuses\n"
"plafond en dalle minérale points lumineux\n"
"cage d'escalier très lumineuse")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.