import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(seuil|d[ée]tecteurs?|variateur|dalles?|seuil)(lumineux?|lumineuses?|luminosit[ée])";
final String string = "locaux lumineux\n"
+ "locaux traversants et lumineux\n"
+ "locaux rénovés sont lumineux\n"
+ "local commercial de 47 m² très lumineux\n\n"
+ "bureaux lumineux\n"
+ "bureaux très lumineux\n"
+ "bureaux haussmaniens ultra-lumineux\n"
+ "bureaux cloisonnés et lumineux\n"
+ "bureaux neufs et lumineux\n"
+ "bureau privatif cosy et lumineux \n"
+ "bureaux agréables et lumineux\n\n"
+ "openspace lumineux\n"
+ "espaces de travail sont lumineux\n"
+ "plateaux très lumineux\n"
+ "plateaux sont très lumineux\n"
+ "duplex atypique et lumineux\n"
+ "bien agencé et lumineux\n\n"
+ "surface lumineuse\n"
+ "boutique très lumineuse\n\n"
+ "locaux en état d'usage belle luminosité\n"
+ "bénéficie d’une luminosité\n"
+ "offrants une grande luminosité\n"
+ "en angle et d’une belle luminosité\n"
+ "verrière apportant élégance et luminosité\n"
+ "belle luminosité\n"
+ "grande luminosité\n"
+ "bonne luminosité\n"
+ "hauteur sous plafond lumineux\n\n"
+ "[NE PAS TENIR COMPTE]\n"
+ "seuil de luminosité\n"
+ "détecteurs présence et luminosité\n"
+ "variateur en fonction de la luminosité\n"
+ "points lumineux\n"
+ "pavés lumineux\n"
+ "zone d'activité lumineuse\n"
+ "dalle quartz belle luminosité\n"
+ "dalles lumineuses\n"
+ "plafond en dalle minérale points lumineux\n"
+ "cage d'escalier très lumineuse";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}