#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((ftp|https?)://(?!.*youtu(be\.de|be\.com|\.be)([:/]|$))[-a-zA-Z?()0-9@:%_+.~#?&;//=]+)"
Local $sString = "Test" & @CRLF & _
"<a href="http://www.example.com">www.example.com</a><br />" & @CRLF & _
"<a href="https://www.example.com">https://www.example.com</a><br />" & @CRLF & _
"<a href="http://example.com">http://example.com</a><br />" & @CRLF & _
"testing" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")