$re = '`((ftp|https?)://(?!.*youtu(be\.de|be\.com|\.be)([:/]|$))[-a-zA-Z?()0-9@:%_+.~#?&;//=]+)`';
$str = 'Test
<a href="http://www.example.com">www.example.com</a><br />
<a href="https://www.example.com">https://www.example.com</a><br />
<a href="http://example.com">http://example.com</a><br />
testing
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);