using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((ftp|https?)://(?!.*youtu(be\.de|be\.com|\.be)([:/]|$))[-a-zA-Z?()0-9@:%_+.~#?&;//=]+)";
string input = @"Test
<a href=""http://www.example.com"">www.example.com</a><br />
<a href=""https://www.example.com"">https://www.example.com</a><br />
<a href=""http://example.com"">http://example.com</a><br />
testing
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}