import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((ftp|https?)://(?!.*youtu(be\\.de|be\\.com|\\.be)([:/]|$))[-a-zA-Z?()0-9@:%_+.~#?&;//=]+)";
final String string = "Test\n"
+ "<a href=\"http://www.example.com\">www.example.com</a><br />\n"
+ "<a href=\"https://www.example.com\">https://www.example.com</a><br />\n"
+ "<a href=\"http://example.com\">http://example.com</a><br />\n"
+ "testing\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}