#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\w+)\/)((\w+)\/*)(.*)$"
Local $sString = "mymodule/overview/do/some/thing" & @CRLF & _
"mymodule/overview/do/some/thing/" & @CRLF & _
"mymodule/overview/" & @CRLF & _
"mymodule/overview" & @CRLF & _
"mymodule/" & @CRLF & _
"mymodule"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")