package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\w+)\/)((\w+)\/*)(.*)$`)
var str = `mymodule/overview/do/some/thing
mymodule/overview/do/some/thing/
mymodule/overview/
mymodule/overview
mymodule/
mymodule`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}