$re = '/^((\w+)\/)((\w+)\/*)(.*)$/m';
$str = 'mymodule/overview/do/some/thing
mymodule/overview/do/some/thing/
mymodule/overview/
mymodule/overview
mymodule/
mymodule';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);