re = /^((\w+)\/)((\w+)\/*)(.*)$/m
str = 'mymodule/overview/do/some/thing
mymodule/overview/do/some/thing/
mymodule/overview/
mymodule/overview
mymodule/
mymodule'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end