package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(solsw-[a-z0-9]{4,}-\d+)`)
var str = `solrs013,121,192.168.1.0/26,r_Labelsolsw-b96m-02,solsw-b96m-01,DEFsolsw-b96l-001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}