re = /(solsw-[a-z0-9]{4,}-\d+)/
str = 'solrs013,121,192.168.1.0/26,r_Labelsolsw-b96m-02,solsw-b96m-01,DEFsolsw-b96l-001'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end