// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(solsw-[a-z0-9]{4,}-\d+)").unwrap();
let string = "solrs013,121,192.168.1.0/26,r_Labelsolsw-b96m-02,solsw-b96m-01,DEFsolsw-b96l-001";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}