# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\*([^*]+)\*/<span style="background:#FFFF00;">$1<\/span>/gm;t' <<< "<vocabulario id=\"01\">
<nota>I got *something* for you</nota>
</vocabulario>
<vocabulario id=\"02\">
<nota>This *gift* is for you</nota>
</vocabulario>
<vocabulario id=\"01\">
<nota>I got *something* for you</nota>
</vocabulario>
<vocabulario id=\"03\">
<nota>Nice *ball*</nota>
</vocabulario>"