const regex = /\*([^*]+)\*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\*([^*]+)\\*', 'gm')
const str = `<vocabulario id="01">
<nota>I got *something* for you</nota>
</vocabulario>
<vocabulario id="02">
<nota>This *gift* is for you</nota>
</vocabulario>
<vocabulario id="01">
<nota>I got *something* for you</nota>
</vocabulario>
<vocabulario id="03">
<nota>Nice *ball*</nota>
</vocabulario>`;
const subst = `<span style="background:#FFFF00;">$1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);