#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\*([^*]+)\*"
Local $sString = "<vocabulario id="01">" & @CRLF & _
" <nota>I got *something* for you</nota>" & @CRLF & _
"</vocabulario>" & @CRLF & _
"<vocabulario id="02">" & @CRLF & _
" <nota>This *gift* is for you</nota>" & @CRLF & _
"</vocabulario>" & @CRLF & _
"<vocabulario id="01">" & @CRLF & _
" <nota>I got *something* for you</nota>" & @CRLF & _
"</vocabulario>" & @CRLF & _
"<vocabulario id="03">" & @CRLF & _
" <nota>Nice *ball*</nota>" & @CRLF & _
"</vocabulario>"
Local $sSubst = "<span style="background:#FFFF00;">$1</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)