$re = '/\*([^*]+)\*/m';
$str = '<vocabulario id="01">
<nota>I got *something* for you</nota>
</vocabulario>
<vocabulario id="02">
<nota>This *gift* is for you</nota>
</vocabulario>
<vocabulario id="01">
<nota>I got *something* for you</nota>
</vocabulario>
<vocabulario id="03">
<nota>Nice *ball*</nota>
</vocabulario>';
$subst = "<span style=\"background:#FFFF00;\">$1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;