import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^.*\\s\\n^(48\\s50\\s20\\s43\\s45\\s32\\s35\\s35\\s41\\s00|48\\s50\\s20\\s43\\s45\\s32\\s35\\s35\\s58\\s00)$(?=.*:\\1=(\\w+))$";
final String string = "42 6C 61 63 6B 20 43 61 72 74 72 69 64 67 65 20 \n"
+ "48 50 20 43 45 32 35 35 58 00\n\n"
+ "Dictionary:48 50 20 43 45 32 35 35 41 00=7000:48 50 20 43 45 32 35 35 58 00=3000\n";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}