const regex = new RegExp('(?s)^.*\\s\\n^(48\\s50\\s20\\s43\\s45\\s32\\s35\\s35\\s41\\s00|48\\s50\\s20\\s43\\s45\\s32\\s35\\s35\\s58\\s00)$(?=.*:\\1=(\\w+))$', 'gm')
const str = `42 6C 61 63 6B 20 43 61 72 74 72 69 64 67 65 20
48 50 20 43 45 32 35 35 58 00
Dictionary:48 50 20 43 45 32 35 35 41 00=7000:48 50 20 43 45 32 35 35 58 00=3000
`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);