# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)^.*\s\n^(48\s50\s20\s43\s45\s32\s35\s35\s41\s00|48\s50\s20\s43\s45\s32\s35\s35\s58\s00)$(?=.*:\1=(\w+))$"
test_str = ("42 6C 61 63 6B 20 43 61 72 74 72 69 64 67 65 20 \n"
"48 50 20 43 45 32 35 35 58 00\n\n"
"Dictionary:48 50 20 43 45 32 35 35 41 00=7000:48 50 20 43 45 32 35 35 58 00=3000\n")
subst = "\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.