$re = '/([^>]){{(.*?)}}/m';
$str = 'The quick brown {{ fox }} jumped over the lazy <em>{{ dog }}</em>';
$subst = "$1<em>$2</em>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;